• 0
skill347

Problem z założeniem serwera w trybie DarkRP

Pytanie

Witam,

jak widać po tytule mam duży problem z założeniem polskiego serwera DarkRP w Garry's Mod.

Nie mogę nigdzie w internecie znaleźć gotowych plików serwerowych (nawet rosyjskich ani angielskich) a wszystkie poradniki

(w wielu językach) nie działają. Wykupiłem serwer na hostingu hostandplay.pl i administracja poleciła mi ten portal. To jest moje marzenie

od zawsze. Pluginy i paczki nie działają. Klikam F4 i nic. Serwer zachowuje się jak sandbox tylko ze jest mapa i jest ULX. Pomocy!

Osoba która mi pomoże może być administratorem albo VIPem. Proszę pilnie o pomoc. Moge udostępnić pliki FTP (pisać na PW)

Załączam logi z konsoli:  Logi 4yourfun.txt

Informacje:

Nasza strona internetowa: http://www.8055.hapgs.net

Mój skype: maks.tym

Nasze IP (serwer jest wyłączony [moge właczyć {napisz na PW}]): GS1.HOSTANDPLAY.PL:10027

Mój profil steam: http://steamcommunity.com/id/SkillGamingPL/

Kontakt mailowy: [email protected]

Preferowany kontakt: PW

Problemy z pobraniem logów? Forma tekstowa:

Cytuj
//shared/misc.lua//
//shared/util.lua//
//shared/hook.lua//
//shared/table.lua//
//shared/player.lua//
//server/player.lua//
//shared/messages.lua//
//shared/commands.lua//
//server/concommand.lua//
//server/util.lua//
//shared/sh_ucl.lua//
//server/ucl.lua//
//server/phys.lua//
//server/player_ext.lua//
//server/entity_ext.lua//
//shared/plugin.lua//
//shared/cami_global.lua//
//shared/cami_ulib.lua//
// Load Complete!//
///////////////////////////////
[ULIB] Loading SHARED module: ulx_init.lua
///////////////////////////////
//ULX Admin Mod//
///////////////////////////////
// Loading...//
//sh_defines.lua//
//lib.lua//
//base.lua//
//sh_base.lua//
//log.lua//
//MODULE: slots.lua//
//MODULE: uteam.lua//
//MODULE: votemap.lua//
//MODULE: xgui_server.lua//
///////////////////////////////
// ULX GUI -- by Stickly Man //
///////////////////////////////
// Adding Main Modules..//
//bans.lua//
//commands.lua//
//groups.lua//
//maps.lua//
//settings.lua//
// Adding Setting Modules..//
//client.lua//
//server.lua//
// Adding Gamemode Modules.. //
//sandbox.lua//
// Loading Server Modules..//
//sv_bans.lua//
//sv_groups.lua//
//sv_maps.lua//
//sv_sandbox.lua//
//sv_settings.lua//
// XGUI modules added!//
///////////////////////////////
//MODULE: chat.lua//
//MODULE: fun.lua//
//MODULE: menus.lua//
//MODULE: rcon.lua//
//MODULE: teleport.lua//
//MODULE: user.lua//
//MODULE: userhelp.lua//
//MODULE: util.lua//
//MODULE: vote.lua//
//end.lua//
// Load Complete!//
///////////////////////////////
SWEP (weapon_ak47custom) is derived from non existant SWEP (weapon_cs_base2) - Expect errors!
HTTP failed - ISteamHTTP isn't available!
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file server.cfg
Using map cycle file cfg/mapcycle.txt.
Couldn't find any entities named dangerbarrels, which point_template hazardbarrel_spawn is specifying.
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
ERROR!: Can't create physics object for models/props/cs_assault/firehydrant.mdl
Precache called on a point_template that has no templates: hazardbarrel_spawn
Nav File is wrong or something (1)
Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
No account token specified; logging into anonymous game server account.(Use sv_setsteamaccount to login to a persistent account.)
Unknown command "sv_defaultgamemode"
Writing cfg/banned_user.cfg.
Connection to Steam servers successful.
Public IP is 151.80.230.84.
Assigned anonymous gameserver Steam ID [A-1:1186181120(8562)].
VAC secure mode is activated.

 

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

16 odpowiedzi na to pytanie

  • 0

Nie widzę aby był tak dodatek o którym Ci wyżej wspomniałem, do tego wszystkich tych pluginów jest całkiem sporo, pamiętaj, że serwer musi wszystko pobrać, a wbijając na serwer również będziesz musiał pobrać pliki z tych pluginów.

1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0
2 minuty temu, Endrju napisał:

Nie widzę aby był tak dodatek o którym Ci wyżej wspomniałem, do tego wszystkich tych pluginów jest całkiem sporo, pamiętaj, że serwer musi wszystko pobrać, a wbijając na serwer również będziesz musiał pobrać pliki z tych pluginów.

W takim razie możesz mi polecić jakąś gotową kolejkę?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0

Patrz wyżej, poleciłem Ci gotowy plugin, kolekcję możesz samemu stworzyć.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0
20 godzin temu, Endrju napisał:

Patrz wyżej, poleciłem Ci gotowy plugin, kolekcję możesz samemu stworzyć.

Wszystko zrobiłem ale tryb DarkRP dalej nie działa (F4 itd...)

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0

Wszystko zrobiłeś tzn co? Więcej informacji podawaj, nwm co konkretnie zrobiłeś, a jeśli zrobiłeś coś źle, a jeśli nie działa to na pewno źle zrobiłeś, to nie jestem wstanie znaleźć przyczyny problemu.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0
1 godzinę temu, Endrju napisał:

Wszystko zrobiłeś tzn co? Więcej informacji podawaj, nwm co konkretnie zrobiłeś, a jeśli zrobiłeś coś źle, a jeśli nie działa to na pewno źle zrobiłeś, to nie jestem wstanie znaleźć przyczyny problemu.

Wrzucilem playliste ktora masz na PW komenda +host_workshop_collection 928***707 (wycenzurowane) ale nie dziala F4. Pozatym bronie auta itd dzialaja :(

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0

Zrobimy to jednak inaczej, nieco łatwiej.

Połącz się z FTP serwera, przejdź do "/garrysmod/gamemodes/" i stwórz tam katalog darkrp, następnie z https://github.com/FPtje/DarkRP pobierz wszystkie pliki(przycisk clone or download) i wgraj je do wcześniej stworzonego katalogu na serwerze. Następnie do komendy startowej serwera dodaj +gamemode darkrp

Sam testowałem i wszystko działa. Musisz jeszcze wgrać pliki z cs:source, ale nwm czy już tego dokonałeś. Jeśli nie to napisz jeśli będziesz miał z tym problem, ponieważ najprawdopodobniej będzie trzeba dokonać tego ręcznie.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0
1 godzinę temu, Endrju napisał:

Zrobimy to jednak inaczej, nieco łatwiej.

Połącz się z FTP serwera, przejdź do "/garrysmod/gamemodes/" i stwórz tam katalog darkrp, następnie z https://github.com/FPtje/DarkRP pobierz wszystkie pliki(przycisk clone or download) i wgraj je do wcześniej stworzonego katalogu na serwerze. Następnie do komendy startowej serwera dodaj +gamemode darkrp

Sam testowałem i wszystko działa. Musisz jeszcze wgrać pliki z cs:source, ale nwm czy już tego dokonałeś. Jeśli nie to napisz jeśli będziesz miał z tym problem, ponieważ najprawdopodobniej będzie trzeba dokonać tego ręcznie.

Ale jak w pliku zip jest folder DarkRP-master to mam go tam wywalic czy mam go wywalic o tak:

gmod/gamemodes/darkrp/DrakRP-master

?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0

Ma być "/garrysmod/gamemodes/darkrp" i tam pliki z linka. Bez DrakRP-master.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0
37 minut temu, Endrju napisał:

Ma być "/garrysmod/gamemodes/darkrp" i tam pliki z linka. Bez DrakRP-master.

F4 dalej nie dziala. Zrobilem to co kazales.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0

U mnie wszystko działa poprawnie, czyli musiałeś coś błędnie skonfigurować skoro nie działa.

Najlepiej daj screena z katalogu "garrysmod/gamemodes/darkrp".

Dodałeś do komendy startowej to o co prosiłem?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
  • 0

Napisano (edytowane)

1 godzinę temu, Endrju napisał:

U mnie wszystko działa poprawnie, czyli musiałeś coś błędnie skonfigurować skoro nie działa.

Najlepiej daj screena z katalogu "garrysmod/gamemodes/darkrp".

Dodałeś do komendy startowej to o co prosiłem?

Masz załączone screeny...

Screeny.png

EDIT:

JA NIE MOGE... Wszystko dziala :D

Dodalem -gamemode zamiast +gamemode :P

Ludzie - uważajcie na takie błędy bo nie warto chwili nie uwagi dla takiej awantury. Nie będe zamykać tego tematu gdybym mial potrzebowac pomocy

ale dziekuje ci drogi Endrju za pomoc i zapraszam na serwer... Czesc :)

EDIT:

Witam, serwer dziala a ja wiem zeby drzwi byly dla danej grupy to trzeba takie cudo:

DarkRP.createEntityGroup("Policja i prezydent", TEAM_POLICE)

Ale gdzie to dac? :P

Edytowane przez skill347
Nowe informacje
0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Żeby dodać komentarz, musisz założyć konto lub zalogować się

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!


Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz